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Using the KODAK PROFESSIONAL HR 500
TWAIN Data Source

with the HR Film Scanners

This document describes how to:

• Install the Kodak Professional TWAIN Data Source on your host computer

• Use the TWAIN Data Source to manipulate and make color corrections to 
scanned images from the:
– Kodak Professional HR 500 Plus Film Scanner
– Kodak Professional HR 500 Film Scanner
– Kodak Professional HR Universal Film Scanner

The TWAIN Data Source allows you to:

• perform color adjustments to a scanned image, either manually or by applying 
a Scene Balance Algorithm

• remove defects using Applied Science Fiction DIGITAL ICE technology

• change the resolution or level of detail of an image

• manipulate an image, either by cropping or using a rotation option

• use your TWAIN-compliant application to further enhance scanned image 
with its modifications

Minimum Hardware Requirements
The Kodak Professional TWAIN Data Source is designed to communicate with 
Windows NT platforms with the following configuration. 

• Pentium II Computer with MMX support

• at least 512 MB memory

• 10 GB available disk space

• Ultra-Wide SCSI board provided with the scanner

A SCSI cable connects the host computer to the HR Film Scanner. This interface 
enables the transfer of digital image data from the scanner to the host computer.

Minimum Software Requirements
Your host computer must be installed with:

• Windows NT 4.0, Service Pack 4 or higher or Windows 2000

• At least one TWAIN-compliant application, such as Adobe Photoshop, version 
5.0, 5.5, or 6.0
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Installing the TWAIN Data Source
1. If the scanner is not powered on, turn on the scanner’s power switch.

Three sets of beeps sound (1st set: one beep, 2nd set: two short beeps, 3rd 
set: two short, then one long beep). 

For the hearing-impaired and as a double-check, the scanner lamp lights and 
remains lit. This means the scanner is “ready.”

2. From your internet Browser, go to 
http://www.kodak.com/global/en/service/software/kproHost

NOTE: You can also use the installation CD packed with the scanner to install 
the TWAIN Data Source.

3. Select HR 500 Film Scanner from the list of products.

4. In the box entitled Driver Software, click KProHR500TWAIN.exe and follow 
the instructions on your screen.

The Kodak Professional HR 500 TWAIN Data Source is now available for use with 
your HR Film Scanner.

Using the TWAIN Data Source with your HR Film 
Scanner

Starting the HR 500 TWAIN Data Source

1. With your host computer’s power off, turn on the scanner’s power switch.
Three sets of beeps sound (1st set: one beep, 2nd set: two short beeps, 3rd 
set: two short, then one long beep). 

For the hearing-impaired and as a double-check, the scanner lamp lights and 
remains lit. The scanner is “ready.”

2. Power on the host computer. Wait until the desktop is displayed.

3. Open your TWAIN-compliant application. This document uses Adobe 
Photoshop as an example.
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NOTE: With Adobe Photoshop, version 6.0, the selection process is simplified. 
You would select File -> Import -> HR500 TWAIN Data Source V3.0.

4. Select File -> Import -> Select TWAIN_32 Source...

NOTE: A version number appears next to “HR500 TWAIN Data Source.”
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5. Highlight HR 500 TWAIN Data Source and click Select.

6. Select File > Import > TWAIN_32.

After the TWAIN Data Source connects to the scanner, the main window appears.
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NOTE: The selections, buttons, and features of this window are explained in detail 
in Description of Functions of the HR 500 TWAIN Data Source on page 10. 

Setting the Controls 

Selecting the Film Type and Size

1. In the Film Selection area of the window, from the Type menu, select the film 
type for the image you will scan.

2. Select the film format from the Format menu.
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Prescanning the Image and Calibrating the Scanner
IMPORTANT: The scanner can store a calibration for a given detail (see Detail on 

page 11) and color filter position (see Filter on page 12) for up to 3 
hours, as long as the scanner is powered on. In situations where it 
was previously necessary to do a new calibration, the stored 
calibration will automatically be used, if one exists for the current 
detail and color filter position.

Note that as long as the scanner is powered on and 3 hours have 
not elapsed, you can enter and exit TWAIN from Photoshop and 
the stored calibrations are remembered. 

1. Click Prescan on the main window.

IMPORTANT: In the next step, if you are using the HR Universal Film Scanner 
and you will be scanning 4x5 images at the magnification and filter 
position being calibrated, use the 4x5 calibration film holder, not the 
70MM-CAL film holder.

2. Insert the empty calibration film holder into the scanner (see the User’s guide 
for your HR Film Scanner for instructions on how to insert film holders in the 
scanner).

NOTE: Make sure the Filter Position is set correctly at the scanner for the type 
of film you will scan.

3. Click OK to begin calibration and wait for calibration to complete. 
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4. Follow the instructions on the screen to insert the film you want to scan, and 
click OK.

When the prescan is complete, the image appears in the TWAIN Data Source 
window.
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Description of Functions of the HR 500 TWAIN Data 
Source

Film Selection

Use the Film Selection area of the window to:

• provide information about the film and the scanned image

• verify that the correct balance filter is selected on the scanner

• calibrate and focus
10 July 2002



Film Type and Format

Use the pull-down menus to select the film type and format.

Resolution

Resolution allows three optional scan resolutions of different quality without the 
need to change the detail slider.

To select the Resolution, select from LOW, MEDIUM, or HIGH.

Detail

The Detail slider changes the pixel dimensions and the number of MB per scan, 
up to a maximum of 127 MB, depending on the film size.

If you change the Detail slider, you must Calibrate and Focus.

NOTE: See the information about stored calibrations under Prescanning the Image 
and Calibrating the Scanner on page 8.

The slider is labeled with the minimum and maximum magnifications for the film 
size at the left and right ends, respectively. Each “tick” mark represents 0.1 
increment in magnification.

NOTE: The right end point is always the highest allowable magnification.

You can control the Detail slider with either the mouse or the keypad on the 
keyboard. When you use the mouse, the effect on the magnification is always in 
increments of 0.1. The table below shows the effect of using the keypad with the 
Detail slider.

* A page is defined as:

• 4 tick marks when there are 12 to 16 tick marks along the slider

• 3 tick marks when there are 8 to 11 tick marks along the slider

• 2 tick marks in all other cases

NOTE: The highest magnification is always rounded to the nearest 0.1 for purposes 
of slider movement. For example, if the highest magnification for a film size 
is 1.19, and the slider is positioned there, pressing the left arrow key sets 
the magnification to 1.10.

Key Effect on Magnification

Left arrow Decrease by 0.1

Up arrow Decrease by 0.1

Right arrow Increase by 0.1

Down arrow Increase by 0.1

Home Set to the minimum value.

End Set to the maximum value.

PgUp Decrease by a page*

PgDn Increase by a page*
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Filter

Filter indicates whether the Negative or Positive balance filter on the scanner is 
selected. 

Rotation

To select the Rotation, select from the list.

Calibrate

Calibrate allows for manual calibration. This requires you to remove any film from 
the scanner and to insert the empty calibration film holder.

IMPORTANT: If you insert a calibration film holder with a film gate aperture that is 
more than 8 pixels wider than the pixel width determined from 
calibration, a message is displayed indicating a possible error and 
you are given the opportunity to cancel the scan. 

It is recommended that you then recalibrate using an appropriate 
calibration gate. If you continue without recalibrating, the scan will 
result in a cropped image.

Focus

Focus allows for a manual refocus. Film must be in the film holder in the scanner 
before you focus.
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Color Adjustments

The Color Adjustments box allows you to:

• view the pixel color at any position in the image

• change the color balance, brightness, and contrast and saturation. 

To see the Red, Green, and Blue values for any position on the image, place the 
cursor in position on the image. The Red, Green, and Blue values for the pixel 
display.

For each color, 1 unit of change is equal to 0.3 color correction (cc) units; 3 clicks 
(you can also type numbers directly to change the values) is approximately 1 cc 
unit. Values for Cyan/Red, Mag/Green, and Yel/Blue can range from -300 to 300.

The Brightness value is added to whatever may be defined by any of the three 
color sliders. The possible values for Brightness are a maximum of -300 to 300, 
with an equal amount of each color added, and including any color changes.

Contrast and saturation values can be from -100 to 100.

NOTE: The color/brightness/contrast/saturation values are saved from one use of 
TWAIN to the next. The next time you open TWAIN, the last-used 
adjustment values will be displayed.

Click View Changes after a Prescan to see the changes on the screen. Click 
Reset Values to reset all values to the defaults.
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Scene Balance

You can allow the HR 500 TWAIN Data Source to use a Scene Balance Algorithm 
to automatically make color adjustments.

1. Select from the dropdown list next to Scene Balance Algorithm (SBA).
There are three options: None (no SBA), Normal, and Enhanced.

Enhanced SBA improves flesh tones under certain lighting conditions.

2. Click Prescan.
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After you view the effects of SBA, you can modify the Cyan/Red, Mag/Green, 
or Yellow/Blue values by entering an offset. The example shows offsets of 
4, 26, and 48.

The SBA adjustments take effect immediately and are maintained until you do 
another Prescan.

The offset adjustments take effect after you click Scan to scan the image. 

If you click Reset Defaults, the offset values return to zeroes.

If you click View Changes, color adjustments, including SBA, are applied to 
the prescanned image.
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Digital ICE Check Box

Digital ICE is a technology (licensed by Kodak from Applied Science Fiction) that 
corrects blemishes and defects on certain negatives and reduces your post-scan 
retouching time.

The Digital ICE check box is grayed out when you select true black-and-white 
films. 

If you scan Kodachrome film with Digital ICE, a message displays stating that 
some Kodachrome images suffer a loss of image detail. You then have the option 
to stop processing with Digital ICE. 

Digital ICE is not intended to correct:

• emulsion-side scratches when the emulsion is damaged

• heavy base-side scratches

• dirt not directly on the film or dirt that moves after calibration

Using Digital ICE is a two-scan process. For best productivity:

• keep the Digital ICE check box cleared (off) when you prescan an image

• correct and crop the image as desired

• select the Digital ICE check box when you are ready to scan the image to 
transfer it to the TWAIN-compliant application

• A note should probably be added in here to the effect that 

NOTE: Including a film gate in a scan when using Digital ICE could cause 
undesirable results such as a distorted image. To eliminate the possible 
effects of including a film gate, 36 pixels are cropped from each edge of a 
scan that uses Digital ICE.

Scan Control

Prescan

Prescan performs a low-resolution scan at the current Detail position and places 
the image in the TWAIN image window. If the Scene Balance Algorithm is 
enabled, SBA offsets are applied to the image and shown in the color sliders.

Scan 

Scan performs a scan based on the color slider offsets, SBA setting, resolution 
setting, detail slider position, and rotation. The scan function then transfers the 
scanned image to the TWAIN-compliant application.

Done

Click Done to end the HR 500 TWAIN Data Source application and return control 
to the TWAIN-compliant application.
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Cropping an Image
You can move the (8) crop handles on the image in the TWAIN window to select a 
portion of the image for scanning.

Below is an example of an image to be cropped. You can click and drag to move 
the crop box and not change the dimensions of the box.

The crop box remains the same until you change it or reset it. To reset the crop 
box, click once outside the crop box.

crop handles
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Below is an example of a cropped scanned image.

You use your TWAIN-compliant application to further enhance the image; for 
example you could remove the red background from the image.

“Use Stored Crop” Check Box

Select the Use Stored Crop check box to use the crop that was in effect when 
TWAIN was last closed (Done was clicked). Once the crop box is visible in the 
preview window, it is the same as any other crop. The default for the Use Stored 
Crop check box is unchecked.

Using the Strip Feed Attachment

If you have a strip feed attached to your scanner and film loaded in the strip feed, 
select the check box next to Strip Feed Attached. 
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The window expands to show Strip Feed options. 

IMPORTANT: When using the Strip Feed Attachment, it is important that the film 
is positioned at an actual image rather than at the strip leader when 
you are ready to focus. It is recommended that if you use the strip 
gate as a calibration gate, you do separate Calibration, Focus and 
Scan (Prescan) operations.
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Features for the Strip Feed Attachment

Each of the four boxes at the bottom of the window contain the four most recently 
scanned images.

Film Size

1. Select either 120 or 135 film size.
The available film formats in the Film Selection area correspond with your 
selection.

2. Select from the menu of film formats in the Film Selection area.

Manual, Auto Advance, and Auto Scan

These selections determine how many frames are scanned when you click Scan.

• When you select Manual, only one frame is scanned, the same as if a cut 
negative were loaded.

• When you select Auto Adv, one frame is scanned, the scanner advances to 
the next frame, then does a prescan.

• When you select Auto Scan, the entire strip is scanned.

NOTE: During an Auto Scan, you can select Stop.

Status

The possible statuses are:

• No Film — the scanner does not detect film.

• Auto — the scanner is detecting frames.

• Manual — the scanner recognizes film, but does not detect a frame.

• Ready — the scanner is waiting for you to select an action.

• Jogging or Moving Film — the film is moving.

• Loading — film is being loaded and threaded into the strip feed attachment.
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Film Advance Buttons
• |<< — Clicking on this button advances to the first frame scanned and does a 

prescan.

• << — Clicking on this button reverses one frame length and does a prescan.

• >> — Clicking on this button advances one frame length and does a prescan.

• >>| — Clicking on this button Advances to the last known frame scanned and 
does a prescan.

Eject Button

When you click the Eject button, the film ejects:

• to the right if the film is visible at both sensors

• to the left if the film is past the right sensor

Jog

Use the Jog slider to move film. Drag the slider to the right to move the film farther 
into the strip gate (moves film to the left); drag the slider to the left to back the film 
out of the gate (moves file to the right). The amount of movement depends on how 
far you move the slider.

You can control the Jog slider with either the mouse or the keypad on the 
keyboard.

The slider moves in millimeter increments until the first image is scanned (either 
with Scan or Prescan). After the first scan, the Jog slider moves in increments 
that are percentages of the size of the image being scanned. The image size 
includes the 30% overscan.
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The tables below show the effect of using the keypad with the Jog slider.

The cumulative amount of movement displays to the right of the slider.

Before First Scan Movement of Film

Left and Up arrows 1 mm to the right

Right and Down arrows 1 mm to the left

Home 50 mm to the right

End 50 mm to the left

PgUp 10 mm to the right

PgDn 10 mm to the left

Mouse 1 mm increments left or right, depending on the 
direction you move the slider

After First Scan Movement of Film

Left and Up arrows To the right, 2% of the image size

Right and Down arrows To the left, 2% of the image size

Home To the right, 50% of the image size

End To the left, 50% of the image size

PgUp To the right, 20% of the image size

PgDn To the left, 20% of the image size

Mouse 2% increments left or right, depending on the 
direction you move the slider
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